Macrium Support Forum

Macrium Support Forum
Macrium Support Forum    RSS 2.0  RSS Feed      KB
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
 All Forums
 Reflect v4
 Disk Imaging
 Corrupt Data
 Forum Locked
 Printer Friendly
Author Previous Topic Topic Next Topic  

docdec
New Member

25 Posts

Posted - July 21 2009 :  15:20:04  Show Profile
Image corruption is always caused by hardware problems and you need to establish what is causing the corruption. If you are using an external USB drive then try a different drive.

- Macrium Support

I have been exploring this error for some time now. It appears the ‘canned’ answer is ‘hardware’. This type of reply can be found not only at Macrium, but also at Acronis. However, I have found it NOT to be a true statement. (If a hardware error, then the defective hardware must be replaced to solve the problem.)

System Stats:
ASUS P4PE-X MOBO
Intel 2.6Ghz Dual CPU
2048 GB Ram
OS = XP Pro SP3
Reflect = Free, Version: 4.2, Build: 2055
2 IDE Channels
- one on the MOBO
- second is a Maxtor PCI ATA 133 controller
IDE Devices – 7
MOBO Primary Controller
Master – 20 GB drive
Slave – Sony DVD

MOBO Secondary Controller
Master – 80 GB drive
Slave – CDROM

Maxtor PCI – Primary Controller
Master – 40 GB drive (OS loaded here – XP PRO SP3)
Slave – 500 GB drive

Maxtor PCE – Secondary Controller
Master – 250 GB drive
Slave - open

This weekend I found a work around for the following type of ‘Data Corrupt’ errors. I copied backup sets from drive G: to drive H: When I went to restore from drive H:, I would receive the dreaded “data corrupt” error. After days of troubleshooting, moving cables, pci card slots, etc, etc, I found this to solve the issue:

From a Dos Prompt:
Copy g:\testback*.mri* h:\*.* /v

Most of the save sets had four files in them. They all may copy from drive g: to h:, OK or you get a ‘verify’ error. The ‘/v’ switch is testing the file after each copy.

If you get a ‘verify’ error, then modify the Dos command to identify the particular file in the save set as failing:

Copy g:\testback1.mri* h:\*.* /v

Working the save sets like this, allowed me to move the save sets from drive G: to drive H: without errors. (All save set images would pass the ‘verify image’ program in Reflect)

We all want valid backups, but it seems the backup programs (Reflect and Acronis) are very, very sensitive about the data. These programs need a BETTER error handling routine when it comes to questionable data. And more important, NOT all “data corrupt” errors are hardware issues.


Nick
Moderator

United Kingdom
6108 Posts

Posted - July 21 2009 :  15:40:50  Show Profile
Hi

Thanks for sharing this information. If you can't copy files consistently using DOS copy then this indicates a probable hardware problem, possibly RAM. You can independently verify the copied files using a tool such as ExactFile http://www.exactfile.com/ . If the hashes are different then the file is corrupt.

Also, If the DOS copy command fails to copy your files without errors then how is this a Macrium Reflect problem?

Kind Regards

Nick - Macrium Support

Go to Top of Page

docdec
New Member

25 Posts

Posted - July 21 2009 :  16:41:42  Show Profile
Thanks Nick for your quick feedback.

First, I’m not suggesting that this is only a Reflect issue. In my first post, I mentioned Acronis backups as well. Therefore, I sense maybe a general ‘backup’ issue across different s/w vendors.

I did try the backups using different quantities of RAM and different IDE controllers, with the same results. I would submit, if I had a ‘hardware’ error, I would show other symptoms as well, such as corruption, unscheduled shutdown, and ‘blue screens’. This is not the case.

Using Window’s ‘copy’ and ‘paste’ would not ever give me a valid backup set. The manner described in the original post (copy [source] [destination] /v ) would work. This MAY save someone some real heartburn down the road.

When problems occur, you look for a common trait, thread, or something to go on. The one thing I did find in common is it happens with both Reflect and True Image 11 backup software. No other programs are misbehaving. Now, I will grant, it MAY be something with my PC. In this business, you never say, ‘never’, because when you do, you’ll get bitten real quickly.

Hope the above helps someone – it took awhile to discover. I’ll test the files before and after a transfer with Exactfile.
Go to Top of Page

ahowes
Starting Member

Australia
2 Posts

Posted - July 22 2009 :  10:00:13  Show Profile
Maxcrium (paid-up version) has successfully destroyed my PC and five years of data.

I backed-up my system to a 16GB USB drive with verify.
I backed-up my data to a separate 16 GB USB drive with verify.
When my system crashed, Macrium told me that my backups were corrupt.

I tried the DOS copy above, it worked successfully for both USB drives.

Obviously this is not a hardware error.

Thanks Macrium - For nothing, I can never trust Macrium to backup my system again.
Go to Top of Page
  Previous Topic Topic Next Topic  
 Forum Locked
 Printer Friendly
Jump To:
Macrium Support Forum © Paramount Software UK Ltd Go To Top Of Page
This page was generated in 0.52 seconds. Snitz Forums 2000